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1 Foreword

1.1 Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who
are familiar with applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing
and commissioning the components. 
It is the duty of the technical personnel to use the documentation published at the respective time of each
installation and commissioning.

The responsible staff must ensure that the application or use of the products described satisfy all the
requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under
development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the
data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, TwinCAT/BSD®, TC/BSD®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®,
Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by
Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own
purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and
patents:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
with corresponding applications or registrations in various other countries.

EtherCAT® is a registered trademark and patented technology, licensed by Beckhoff Automation GmbH,
Germany

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to
others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a
patent, utility model or design.
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1.2 Safety instructions

Safety regulations

Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring,
commissioning etc.

Exclusion of liability

All the components are supplied in particular hardware and software configurations appropriate for the
application. Modifications to hardware or software configurations other than those described in the
documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for trained specialists in control, automation and drive engineering who are
familiar with the applicable national standards.

Description of symbols

In this documentation the following symbols are used with an accompanying safety instruction or note. The
safety instructions must be read carefully and followed without fail!

 DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of
persons.

 WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of per-
sons.

 CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.

NOTE
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or
equipment.

Tip or pointer
This symbol indicates information that contributes to better understanding.
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1.3 Notes on information security
The products of Beckhoff Automation GmbH & Co. KG (Beckhoff), insofar as they can be accessed online,
are equipped with security functions that support the secure operation of plants, systems, machines and
networks. Despite the security functions, the creation, implementation and constant updating of a holistic
security concept for the operation are necessary to protect the respective plant, system, machine and
networks against cyber threats. The products sold by Beckhoff are only part of the overall security concept.
The customer is responsible for preventing unauthorized access by third parties to its equipment, systems,
machines and networks. The latter should be connected to the corporate network or the Internet only if
appropriate protective measures have been set up.

In addition, the recommendations from Beckhoff regarding appropriate protective measures should be
observed. Further information regarding information security and industrial security can be found in our
https://www.beckhoff.com/secguide.

Beckhoff products and solutions undergo continuous further development. This also applies to security
functions. In light of this continuous further development, Beckhoff expressly recommends that the products
are kept up to date at all times and that updates are installed for the products once they have been made
available. Using outdated or unsupported product versions can increase the risk of cyber threats.

To stay informed about information security for Beckhoff products, subscribe to the RSS feed at https://
www.beckhoff.com/secinfo.

https://www.beckhoff.com/secguide
https://www.beckhoff.com/secinfo
https://www.beckhoff.com/secinfo
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2 Overview
The TwinCAT ECAD Import Tool completes the engineering chain: Everything happens automatically without
user intervention, from electrical design to PLC projects. The achievable reduction in input and transmission
errors ultimately also reduces costs. From an ECAD program, the required information about the structure of
the I/Os and the linkage to PLC variables is exported via XML. Beckhoff uses an XML schema for specifying
the structure of the XML file. The TwinCAT ECAD Tool reads the XML file and generates a TwinCAT System
Manager configuration with all I/O devices, Bus Terminals and Fieldbus Box modules, and a basic PLC
program with the I/O variables used.

A software device hierarchy can be created by importing a further XML file. An NC device with tasks, axes
and, obviously, I/O variables can be created automatically. For this too, links with PLC variables can be
generated automatically. Corrections in the ECAD construction drawings can be implemented at any time.
Any changes that may be required in the System Manager or the PLC program are carried out automatically,
as far as possible.

In another direction, the TwinCAT ECAD Tool can produce the specified XML file from an existing TwinCAT
System Manager configuration file. This provides an ECAD program an opportunity to get the information of
I/Os configuration and then generate or modify the ECAD construction drawings.

The concept of TwinCAT ECAD Tool

2.1 Release Note
TcEcadImport Version 2.0.1.9

User interface is modified. New properties are added to Teip project.

IoGroup [} 28] is extended for the Variables of EthereCAT devices in ECAD2TwinCAT.xsd.

Link [} 37] is extended in Box and Terminal for the linked Nc/CNC Axis, Encoder or Drive.
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TcEcadImport   Version 2.0.0.0

New user interface.

Connection [} 35] is extended for EtherCAT devices in ECAD2TwinCAT.xsd.
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3 Installation
System requirements:

1) Windows NT\2000\XP.

2) TwinCAT version 2.9 (Build 1030) or higher.

* If EtherCAT is desired, TwinCAT version 2.11 have to be installed.

3) .Net Framework 3.5 SP1.
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4 User Interface
ü After installation, TwinCAT ECAD Import can be found under TwinCAT System in “All programs” of the

Windows “start” menu.
1. A dialog as below will show up after the program started.

Main dialog

2. Make a new Project via either the menu "File/New/Project" or  in the toolbar. Give a filename for the
Project. The content for a TwinCAT ECAD Import Project (Teip) will be shown in the following dialog.
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TwinCAT ECAD Import Project (Teip) Dialog

3. Click "OK" to continue, if the required settings are done. The ECAD files will be loaded or prepared. The
results will be shown in the Data View. The property view on the right side will show the details of the
selected ECAD item.
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4. Click menu "Action/Import ECAD to TwinCAT" or in the tool bar. The TwinCAT System Manger and
PLC Control Project files will be generated or updated. A message will be shown after the action is
excuted. The generated/updated TwinCAT project files can be opened via the menu "Tools/View tsm" or
"Tools/View pro".

4.1 Dialogs

4.1.1 Main dialog
The main dialog contains the following parts:

1) Menu and toolbar part.

2) ECAD Data View and the property window

3) Output, Error List and Commands windows.

4) Processbar and status info label.

Main dialog

4.1.2 TwinCAT ECAD Import Project (Teip)
The following dialog will be shown if File/New/Project [} 16] or Project/Properties [} 17] is clicked. It
decides which ECAD import/export Files and TwinCAT Project files are included in the project.
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Teip dialog

The inputs are grouped in 4 Categories:

1) General

Name shows the name of the Teip.

Author is an option.

2) TwinCAT

System Manager Project File for Import/Export is obligatory for a Teip. The file will be generated/updated
via importing an ECAD file. Or an ECAD exporting file will be generated/updated via exporting the TwinCAT
files.

PLC Control Project File for Import/Export is obligatory for a Teip. The file will be generated/updated via
importing an ECAD file. Or an ECAD exporting file will be generated/updated via exporting the TwinCAT
files.

3) Import

Import action option decides if the TwinCAT Projects will be rebuild or refreshed.

if Load available PLC projectsis true, the PLC project will not be generated, but only be loaded for mapping
variables.

ifTry to validate IoDataType with TwinCATis true, the given DataType in ECAD xml file will be validated with
System Manager IO Variable data types.

ECAD File for Import to TwinCAT is obligatory for a Teip. This file is available from the ECAD Construction
Drawings Program, which exports such files following the schema "ECAD2TWINCAT.xsd".

--- ECAD Device File for Import to TwinCAT (Option) is a separate ECAD file, which only contains the
"Devices [} 23]" Information.
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Naming Rules File for Import to TwinCATis an option, if there are any rules for replacing the special
characters reading from the ECAD file, e.g. "ue" replacing "ü".

4) Export

ECAD File for Export from TwinCAT has to be decided, if TwinCAT System Manager and/or PLC Control
Project files are existing and you want to export an ECAD file via TwinCAT ECAD Import Tool.

Export exact type indicates if an exact Product-Revision type for EtherCAT devices will be obtained or not.

Ingnore Index and SubIndex in IoName and IoGroup of Variables should always be False, the exact variable
information will be exported.

4.1.3 Rules file
The following dialog will be shown if File/New/Rules or File/Open/Rules [} 16] is clicked. It defines the rules,
which characters in the Names of the Interface, Box, Terminal, IO Variable or PLC Variable are replaced with
other characters, without changing the content of an ECAD file.
This Naming Rules file then can be included in the Teip.
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4.2 Menu and toolbar

4.2.1 File

The File menu

File menu includes the following menu items:

New/Project: Create a new TwinCAT ECAD Import Project (Teip), same as toolbar button 

New Rules: Create a new Naming Rules file. The Rules File Dialog [} 15] will be shown.

Open/Project: Open an existing Teip file, same as toolbar button .

Open/Rules: Open an existing Naming Rules file. The Rules File Dialog [} 15] will be shown.

Save Project: Save the current opening Teip file, same as toolbar button .

Save Project as...: Save the current opening Teip file with another filename.

Recent Projects: Shows a list of recent opened Teip files.

Close Project. Close the current openend Teip project.

Exit: Closes TwinCAT ECAD Import.

4.2.2 Action
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The Action menu

Action menu includes the following menu items:

Import ECAD to TwinCAT: Generate/update the TwinCAT System Manager and PLC Control Projects file

via importing an ECAD file, same as toolbar button .

Export ECAD from TwinCAT: Generate/update an ECAD file following the "ECAD2TWINCAT.xsd" schema

with ".tc2ecad" extension, same as toolbar button .

Refresh ECAD Data View/All: Reload ECAD import file and reconstruct ECAD export data from the
TwinCAT projects.

Refresh ECAD Data View/ECAD to TwinCAT: Only reload ECAD import file.

Refresh ECAD Data View/ECAD from TwinCAT: Only reconstruct ECAD export data from the TwinCAT
projects.

4.2.3 Project

The Project menu

Project/Properties: Opens the Properties dialog as below for the current opened Teip file. If the properties
are changed, the ECAD Data will be updated.
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4.2.4 Tools

The Tools menu

Tools/View tsm: Opens the TwinCAT System Manager Project file, which is included in the current opened
Teip file.

Tools/View pro: Opens the PLC Control Project file, which is included in the current opened Teip file.

Tools/View list of Io types: Shows a list of System Manager IO types. The corresponding ECAD types can
be checked.
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IO type selector dialog

4.2.5 Help

The help menu

Help/Contents: Opens this document.

Help/About: Shows the about dialog as below.
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5 Appendix

5.1 ECAD export XML file
ECAD export XML file is required in Import dialog togenerate a TwinCAT System Manager configuration and
its corresponding PLC program.It contents the required information about the structure of the I/Os and the
linkage to PLC variables. Beckhoff uses an XML schema for specifying the structure of the XML file. This
schema file named ECAD2TwinCAT.xsd and its related TcBaseTypes.xsd can be found under the installed
TcEcad folder.

Here is a simple example of ECAD export XML file.
<?xml version="1.0" encoding="UTF-8"?>
<Project>
  <Name><![CDATA[SOMENAME XML]]></Name>
  <Author><![CDATA[UNKOWN]]></Author>
  <Version>1.0</Version>
  <Description><![CDATA[SOMEDESCRIPTION]]></Description>
  <ChangeDate>2003-10-14T13:18:44</ChangeDate>
  <CPUs>
    <CPU>
      <Name><![CDATA[CPU1]]></Name>
      <Interfaces>
        <Interface>
          <Name><![CDATA[FB1]]></Name>
          <Comment><![CDATA[Interfacekommentar]]></Comment>
          <Type><![CDATA[FC2002]]></Type>
          <ChannelNo>1</ChannelNo>
          <Boxes>
            <Box>
              <Name><![CDATA[LBF1]]></Name>
              <Comment><![CDATA[BK2000]]></Comment>
              <Type><![CDATA[BK2000]]></Type>
              <BoxNo>1</BoxNo>
              <Variables>
                <Variable>
                  <Name><![CDATA[byAF1Status]]></Name>
                  <IsInput>1</IsInput>
                  <Comment><![CDATA[LWL-BUS-Koppler Klemmstelle 1 Festseite]]></Comment>
                  <IoName><![CDATA[State]]></IoName>
                  <IoDataType>BYTE</IoDataType>
                </Variable>
              </Variables>
              <Terminals>
                <Terminal>
                  <Name><![CDATA[Q01]]></Name>
                  <Comment><![CDATA[Terminalkommentar]]></Comment>
                  <Type><![CDATA[KL2032]]></Type>
                  <Channels>
                    <Channel>
                      <Name><![CDATA[A01]]></Name>
                      <Comment><![CDATA[]]></Comment>
                      <Variables>
                        <Variable>
                          <Name><![CDATA[bQHF1FormatbYSchnellMinus]]></Name>
                          <IsInput>0</IsInput>
                          <Comment><![CDATA[Formatbearbeitung Y-Achse schnell minus]]></Comment>
                          <IoDataType>Bool</IoDataType>
                        </Variable>
                      </Variables>
                    </Channel>
                    <Channel>
                      <Name><![CDATA[A02]]></Name>
                      <Comment><![CDATA[]]></Comment>
                      <Variables>
                        <Variable>
                          <Name><![CDATA[bQHF1FormatbYLangsMinus]]></Name>
                          <IsInput>0</IsInput>
                          <Comment><![CDATA[Formatbearbeitung Y-Achse langsam minus]]></Comment>
                          <IoDataType>Bool</IoDataType>
                        </Variable>
                      </Variables>
                    </Channel>
                  </Channels>
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                </Terminal>
              </Terminals>
            </Box>
          </Boxes>
        </Interface>
        <Interface>
          <Name><![CDATA[FB1]]></Name>
          <Comment><![CDATA[Interfacekommentar]]></Comment>
          <Type><![CDATA[FC2002]]></Type>
          <ChannelNo>2</ChannelNo>
        </Interface>
      </Interfaces>
    </CPU>
  </CPUs>
</Project>

5.2 ECAT2TwinCAT.xsd
This XML schema file defines the structure of the ECAD export XML file.The definitions of each xml element
in ECAD2TwinCAT.xsd are briefly summarized as below. In following graphics, the elements with solid line
means must-be, e.g, all Name elements. Meanwhile, the elements with dashed-line mean that they are
optional, e.g. all Comment elements.

5.2.1 Project
Projectis the root element. In Name, Author, Description should be written in <![CDATA[]]>. DataTypes
defines the data types used in PLC program. It could be ignored in an ECAD exported XML file, as the same
as in sample “AT002V2.xml”.

5.2.2 CPU
CPUsincludes at this moment only one element CPU. This CPU corresponds to one System Manager
Project.
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5.2.3 Devices

5.2.3.1 Device

Device defines different configurations in System Manager, e.g. a PLC project.

For instance, the below is a case of a PLC project.
<Device>
  <Name><![CDATA[AT002]]></Name>
  <Comment/>
  <Type>PLC</Type>
  <Address>801</Address>
  <Modules/>
  <Tasks>
    <Task>
      <Name><![CDATA[Standard]]></Name>
      <Comment><![CDATA[Taskdes IEC61131 Projekts "AT002"]]></Comment>
      <Type>PLC</Type>
      <Calls>
        <ProgramCall>Main()</ProgramCall>
      </Calls>
      <Priority>0</Priority>
      <CycleTime>10000</CycleTime>
    </Task>
  </Tasks>
</Device>

in a case of Nc:
<Device>
  <Name><![CDATA[NC - Configuration]]></Name>
  <Comment/>
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  <Type>NC</Type>
  <Address>500</Address>
  <Modules>
    <Module>
      <Name><![CDATA[Achse 1 (Oberdruck)]]></Name>
      <Comment/>
      <Type>NCAXIS</Type>
      <SubType>2</SubType>
      <ModuleNo>1</ModuleNo>
      <Childs>
        <Child>
          <Name><![CDATA[Achse 1 (Oberdruck)_Enc]]></Name>
          <Comment/>
          <Type>NCENCODER</Type>
          <SubType>4</SubType>
          <ModuleNo>1</ModuleNo>
          <Variables>
            <Variable>
              <Name><![CDATA[Achse 1 (Oberdruck)_Enc_In^nInData1^nInData1[0]]]></Name>
              <Comment/>
              <DataType>UINT16</DataType>
              <IsInput>true</IsInput>
              <LinkedWith>
                <Name><![CDATA[Counter]]></Name>
                <DataType>UINT16</DataType>
                <IsInput>true</IsInput>
                <Device>IO</Device>
              </LinkedWith>
              ....
            </Modules>
            <Tasks>
              <Task>
                <Name><![CDATA[NC-Task 1 SAF]]></Name>
                <Comment/>
                <Type>NC SAF</Type>
                <Priority>0</Priority>
                <CycleTime>4000</CycleTime>
              </Task>
              <Task>
                <Name><![CDATA[NC-Task 1 SVB]]></Name>
                <Comment/>
                <Type>NC SVB</Type>
                <Priority>1</Priority>
                <CycleTime>10000</CycleTime>
              </Task>
            </Tasks>
          </Device>

5.2.3.2 Modules (Device)
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Modules are a collection of NC axes, NC channels in TwinCAT System Manager.

The Type for a NC axis should be "NCAXIS" and "NCCHANNEL" for NC channel.

For a NC axis, the SubType can be:

1, for Continuous Axis;

2, for Discrete Axis (two speed);

3, for Low Cost Stepper Axis (dig. I/O);

5, for Encoder Axis (virtual axis)...

The Variables can be found directly under a LineMotion module. (under construction).

Childs are the same ComponentType in schema file. They present the members and a NC axis, for
example.

5.2.3.3 Childs
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Childs are the same ComponentType in schema file. They present the members and a NC axis, for
example.

The Type should be "NCENCODER" for a Axis encoder; "NCDRIVE" for a Axis drive; "NCCONTROLLER"
for a Axis controller.

The SubType should be "1" for Simulations-Encoder, for example.

5.2.3.4 Variables

Variables is a collection of the ComponentType. They present the members of a NC axis, for example.

The Type should be "NCENCODER" for a Axis encoder, "NCDRIVE" for a Axis drive and
"NCCONTROLLER" for a Axis controller.

The SubType should be "1" for Simulations-Encoder, for example.

LinkedWith defines the variable which is linked with this variable. The Linkedwith variable can be in PLC, NC
or IO configurations. Thus, "PLC1","PLC2","PLC3","PLC4", "PLC" as default of "PLC1, or "NC", "LM", "IO"
has to be included in Device tag.

5.2.3.5 Tasks
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Tasks is a collection of Task under a PLC, NC, LineMotion and so on.

The Name is the name of taks, e.g "T1_Slow".

The Type should be "PLC" for Plc tasks; "NC SAF" for NC SAF task; "NC SVB" for NC SVB task.

Calls are the programs, which the task calls, e.g.
<Calls>
  <ProgramCall>Main()</ProgramCall>
</Calls>

5.2.4 Interfaces

5.2.4.1 Interface

Interfaces defines the Fieldbus cards under IO-Devices of IO configuration in System Manager.
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A Fieldbus card can have more than one channel, e.g 2xLight Bus in one card. These 2 channels will be
treated as 2 cards in System Manager. In this case, the Name of the Fieldbus can be the same, but the
ChannelNo has to be different. As the XML file is imported to generate a System Manager, 2 cards with the
name of Name_ChannelNo will be created in System Manager. For Instance, an interface Name= FB,
ChannelNo=1 in a XML file, will correspond an IO-Device called “FB_1”.

As observed in System Manager, the Inputs/Outputs of a Fieldbus card can directly linked with PLC
variables. The information can be also included in the XML file, as described in the next section.

Box es defines the Bus couplers, which are connected with a Fieldbus card.

5.2.4.2 Variables

Variable can be found in different places: Interfaces, Boxes and Channels.

Name is the linked PLC or NC variable name.
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IoName is the name of an IO variable shown in System Manager.In case of Variable under Interface and
Box, the IoName must be the same as the one in System Manager.

IoDataType is the IEC data type of the PLC variable.

IsInput is used for variable definition in TwinCAT PLC Control. For example, in PLC project,
myInVar AT%I* : BOOL; 
myOutVar AT%Q* : BOOL;

%I indicates input, %Q indicates output.

Instance is used to link a variable in a Device like NC or PLC. In case of NC, the Name should be the parent
module name, like "Axis1" or "Axis1^Axis_Enc". In case of PLC, in future it would be also used to link non-
globe PLC variable, e.g. a Function Block’s variable (under construction)

Destination defines in which Device and Task the Variable should be linked.

An example of Variable is like,
<Variable>
  <Name><![CDATA[nInData1[0]]]></Name>
  <IsInput>true</IsInput>
  <IoName>Counter</IoName>
  <IoDataType>UINT16</IoDataType>
  <Instance>
    <Name><![CDATA[Achse 1 (Oberdruck)^Achse 1 (Oberdruck)_Enc]]></Name>
    <DataType>UINT16ARR2</DataType>
    <IsInput>true</IsInput>
  </Instance>
  <Destination>
    <Device>NC</Device>
    <Task>NC-Task 1 SAF</Task>
  </Destination>
</Variable>

And the linked variable in the device has to be,
<Variable>
  <Name><![CDATA[Achse 1 (Oberdruck)_Enc_In^nInData1^nInData1[0]]]></Name>
  <DataType>UINT16</DataType>
  <IsInput>true</IsInput>
  <LinkedWith>
    <Name><![CDATA[Counter]]></Name>
    <DataType>UINT16</DataType>
    <IsInput>true</IsInput>
    <Device>IO</Device>
  </LinkedWith>
</Variable>
Info:

Info:

The Variable under a Channel is somehow different from the one under Interface or Box. There is
generally only one (e.g. in case of a Digital Terminal) or only one interesting variable under a channel. In this
case, the IoName could be named as desired, and IsInput could be omitted. However if another non-default
IO variable under a Channel is requested to link with a PLC variable, IoName has to be the same as the one
in System Manager.

New: since the version 2.0.1.9, the following extension specially for the EtherCAT slaves is added:

IoGroup is obligatroy for an EtherCAT Slave's Variables. It is the name of the variable group as shown in the
following figure. IoGroup can have the Index attribute, which should be the same as the Index of the PDO
item's Index.

IoNamecan now have the optional Attributes Index, SubIndex and IndexInArray, which should be the same
as the ones of the Entries in Process Data of an EtherCAT slave. IndexInArray is necessary if the Variable
is an element of an array.
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5.2.4.3 Boxes

Boxes describes the Boxes in the System Manager, e.g. Fieldbus coupler. From the version 2.0.0.0, all
EtherCAT members are treated as Box type.

Name and Comment have the same content as in System Manager. Type should be the abbreviate name
which could be found in TcTerminals.xml.

Type is necessary for System Manager to append the correct Box. Normally it is just the short name of the
type shown in System Manager, e.g. BK2000.
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There are two cases, which have to be treated specially.

1) For EtherCAT boxes, the Interface of the boxes has to be "ETHERCAT" Type . The Type of a EtherCAT
box can be given in an exact or short format. For instance, "BK1120-0000-9998" is the exact Type for a
BK1120, which can be found on the EtherCAT tab of an EtherCAT Box property settings. If the short format
of "BK1120" is given, the latest Revision (e.g. "BK1120-0000-0000" ) will be imported.

It will be included in the Ecad Xml File, as
<Interfaces>
  <Interface>
    <Name><![CDATA[FB1_1]]></Name>
    <Comment/>
    <Type>ETHERCAT</Type>
    <Boxes>
      <Box>
        <Name><![CDATA[BKF33]]></Name>
        <Comment/>
        <Type>BK1120-0000-9998</Type>
        <BoxNo>5</BoxNo>
        <Terminals>
          ...

Or in general, especially for the third party products, the code should be given in format
"V%8X_P%8X_R%8X_S%8X", e.g.

V00000002_P04602C22_R270E0000

V: Vendor code, e.g. it is 2 for Beckhoff products.

P: Product code.

R: Revision number, optional.

S: Serial number, optional.

%8X: a number in hex format and 8 length.
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2) For Profibus boxes:

If the Profibus box is a Beckhoff Product, "BK3XXX" should be given in <Type> tag. Otherwise it should be
"PBDP_GSD".

To give the exact Type information, the Production Name or Module Name in GSD file must be included in
<ProductName> tag in <AdditionalInfo> tag, e.g. IL230x-B310, which is listed in Beckhoff Catalog.
<Interfaces>
  <Interface>
    <Name><![CDATA[Pos.650 Sorter201 (FC310x)]]></Name>
    <Comment/>
    <Type>FC3100</Type>
    <Boxes>
      <Box>
        <Name><![CDATA[Coupler box IL230x-Bxxx]]></Name>
        <Comment/>
        <AdditionalInfo>
          <ProductName>IL2302-B310</ProductName>
        </AdditionalInfo>
        <Type>BK3XXX</Type>
        <BoxNo>5</BoxNo>
        <Terminals>
          ...

See the next section "AdditionalInfo" to get more detail information.

BoxNo is the physical topography of the box, identical with the number of “Id:” in System Manager.

The topography for LightBus is very important, but not for Profibus.

Connection [} 35] is a special Element for giving connectivity information of EtherCAT box. It is especially
useful for such EtherCAT boxes with more than 1 EtherNet port, like EtherCAT junction EK1122.

Variables [} 28] defines the linked I/O variables of a Box and PLC variables, as given in the last section.

Terminals [} 35] represents the I/O terminal cards extended to a Box.

AdditionalInfo [} 32] and Modules [} 36] are used optionally for such as Profibus and DeviceNet. 
AdditionalInfo [} 32] provides the possibility especially for third-party products to include the additional
information. 
Modules [} 36] give the information of Profibus modules.

Link [} 37] provides information of linked NC/CNC Axis, Encoder or Drive of the Box.

5.2.4.4 AdditionalInfo

In general, ProductName has to be the same name as Model_Name in a GSD file, or ProdName in an EDS
file. If it is a Beckhoff Product, the Product Name listed in Beckhoff Catalog can be used.
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The detail information can be given in two ways: either the absolute Path of the file name, or integrated the
whole file in ConfigFile section, a sample shown as below
<Interface>
  <Name><![CDATA[Device 1 (CX1500-M310)]]></Name>
  <Type>CX1500_M310</Type>
  <ChannelNo>1</ChannelNo>
  <Boxes>
    <Box>
      <Name><![CDATA[Bosch-VI1 (GSD Box) (RMVDP/F)]]></Name>
      <Comment><![CDATA[Vendor: Robert Bosch GmbH, 64701 Erbach Revision: 1.0]]></Comment>
      <AdditionalInfo>
        <ProductName>RMVDP/F</ProductName>
        <Path>C:\GSDBox\Rb010118.gsd</Path>
        <ConfigFile><![CDATA[
;************************************************************************ 
;*** ***any commons....
;************************************************************************ 
;*************************************************************************
;
#Profibus_DP
;
;*************************************************************************
; Allgemeine Daten
;*************************************************************************
;
;Versionskennung des GSD-Dateiformats
GSD_Revision = 2
;
; Herstellername
Vendor_Name = "Robert Bosch GmbH, 64701 Erbach"
;
; Geraetebezeichnung
Model_Name = "RMVDP/F"
;
; Ausgabestand des DP-Geraetes
Revision = "1.0"
;
; Typnummer
Ident_Number = 0x0118
;
; Protokollkennung
Protocol_Ident = 0
;
; DP-Geraetetyp
Station_Type = 0
;
; Hardware-Ausgabestand
Hardware_Release = "V1.0"
;
; Software-Ausgabestand
Software_Release = "----"
;
; Unterstuetzte Baudraten
9.6_supp = 1
19.2_supp = 1
93.75_supp = 1
187.5_supp = 1
500_supp = 1
1.5M_supp = 1
3M_supp = 1
6M_supp = 1
12M_supp = 1
;
; Maximale Protokoll-Bearbeitungszeit
MaxTsdr_9.6 = 60
MaxTsdr_19.2 = 60
MaxTsdr_93.75 = 60
MaxTsdr_187.5 = 60
MaxTsdr_500 = 100
MaxTsdr_1.5M = 150
MaxTsdr_3M = 250
MaxTsdr_6M = 450
MaxTsdr_12M = 800
;
;Geraeteunterstuetzung redundanter Uebertragungstechnik
Redundancy = 0
;
; Pegel des Repeater-Steuersignals CNTR-P
Repeater_Ctrl_Sig = 0
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;
; Bitmap-Datei
Bitmap_Device = "RBxxRM_M"
;
; Realisierungs-Typ LSPM2 Version B
Implementation_Type = "LSPM2-B"
;
;*************************************************************************
; spezifische Daten des Busteilnehmers
;*************************************************************************
;
; DP-Geraet unterstuetzt den Freeze-Mode
Freeze_Mode_supp = 1
;
; DP-Geraet unterstuetzt den Sync-Mode
Sync_Mode_supp = 1
;
; Automatische Baudratenerkennung
Auto_Baud_supp = 1
;
; Unterstuetzung der Busteilnehmer-Adressierung
Set_Slave_Add_supp = 0
;
; Hoechstlaenge des herstellerspezifischen Feldes
User_Prm_Data_Len = 0x05
;
; Herstellerspezifisches Feld
User_Prm_Data = 0x00,0x00,0x00,0x00,0x00
;
; Minimaler Abstand zwischen zwei Zugriffen auf den Busteilnehmer
Min_Slave_Intervall = 1
;
; Busteilnehmertyp
Modular_Station = 1
;
; Hoechstanzahl der Module einer modularen Station
Max_Module = 1
;
; Hoechstlaenge der Eingangsdaten einer modularen Station in Bytes
Max_Input_Len = 0
;
; Hoechstlaenge der Ausgangsdaten einer modularen Station in Bytes
Max_Output_Len = 4
;
; Groesste Summe der Laengen der Ein- und Ausgangsdaten einer modularen Station
Max_Data_Len = 4
;
;Geraetespezifische Diagnosemeldungen
Unit_Diag_Bit(0) = "Kurzschluss Ventile"
Unit_Diag_Bit(1) = "Unterspannung UQ1"
Unit_Diag_Bit(2) = "Unterspannung UQ2"
Unit_Diag_Bit(3) = "UQ1 nicht vorhanden"
Unit_Diag_Bit(4) = "UQ2 nicht vorhanden"
;
; Hoechstlaenge der Diagnoseinformation (Diag_Data)
Max_Diag_Data_Len = 13
;
; Funktionsklasse: I/O
Slave_Family = 3@Bosch
;
; Modulkennung
;------------------------------------------------------------------------------
;
Module = "Ventile 1-16" 0x23, 0x00
0
EndModule
Module = "KT-Ventile 1-12" 0x22, 0x00
1
EndModule
;
;********************* Ende der Geraetestammdatendatei *********************

]]>
        </ConfigFile>
      </AdditionalInfo>
      <Type>PBDP_GSD</Type>
      <BoxNo>1</BoxNo>
      <Modules>
        <Module>
          <Name><![CDATA[Ventile 1-16]]></Name>
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          <Comment/>
          <Type>0</Type>
          <Variables>
            <Variable>
              <Name><![CDATA[]]></Name>
              <IsInput>false</IsInput>
              <Comment/>
              <IoName>Ventile 1-16_1_0</IoName>
              <IoDataType>BYTE_ARRAY_0_3</IoDataType>
            </Variable>
            .....
           

5.2.4.5 Connection

This element is only required if there is an EtherCAT member, which has two or more ethernet ports. For
instance, the EtherCAT junction "EK1122" has two ports, labeled with "X1" and "X2". Individual devices or
complete EtherCAT strands can be connected at he junction ports. The TwinCAT ECAD Import then needs
to know which devices are connected at which junction port. Therefore in the ECAD file a unique ConnectId
for EK1122 has to be given. And the PreviousId and PreviousPort have to be given for the sidelined device.
An example is shown as below:
<Interface>
  <Name><![CDATA[Device 1 (EtherCAT)]]></Name>
  <Type>ETHERCAT</Type>
  <ChannelNo>1</ChannelNo>
  <Boxes>
    ...
    <Box>
      <Name><![CDATA[Term 12 (EK1122)]]></Name>
      <Type>EK1122-0000-0016</Type>
      <BoxNo>1012</BoxNo>
      <Connection>
        <ConnectId>1012</ConnecId>
      <Connection>
          ....
    </Box>
    <Box>
      <Name><![CDATA[Term 40(EK1100)]]></Name>
      <Type>EK1100-0000-0001</Type>
      <BoxNo>1040</BoxNo>
      <Connection>
        <PreviousId>1012</ConnecId>
        <PreviousPort>X1</ConnecId>
      <Connection>
              ....
    </Box>

5.2.4.6 Terminals
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Terminals contains the list of Bus terminals. 
Typeis the terminal type. The type number, which System Manager uses for appending, is just the number
from the terminal symbol (KL2004->2004). There is an exception, if the terminal has subtypes. Some
terminals have compact (fewer variables) and complex with additional variables for status and diagnosis.
Then a compact terminal has a subtype, which is identified like "KL3001-1".

Channels [} 36] contains the channels of the terminal.

Link [} 37] contains information of the linked NC/CNC Axis, Encoder or Drive of the Terminal.

5.2.4.7 Channels

The Channels represent the channels of a terminal in a System Manager file. Name and Comment will
taken as they are.

One Channel can have one or more variables, depending on the terminal types.

5.2.4.8 Modules (Box)
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Modulesunder a Box are similar as Terminals but without channels, the variables are found directly under a
Module. They are used specially in the case of GSD file.

5.2.4.9 Link in Box and Terminal

Link contains information of the linked NC or CNC Axis, Encoder or Drive of a Box resp. Terminal. e.g.
<Box>
  <Name><![CDATA[BKF21_I20 (OF1-Einzug Messrad)]]></Name>
  <Comment><![CDATA[]]></Comment>
  <Type>EL5151</Type>
  <BoxNo>8</BoxNo>
  <Connection>
    <ConnectId>1007</ConnectId>
    <PreviousId>1006</PreviousId>
  </Connection>
  <Link AxisName="Achse 7 Servokanteneinzug T3 (OF1)" Target="Encoder" Targe-tId="2">NC</Link>
</Box>

5.3 Example: Using EPLAN P8 Data in TwinCAT
The following application provides a solution to reuse EPLAN P8 data in TwinCAT. This reuse is based on a
XML-file defined by Beckhoff. The TwinCAT ECAD import tool uses this XML file to create a TwinCAT
configuration.

The example contains an EPLAN P8 project, the exported XML file from EPLAN and the TwinCAT
configuration.  So the example shows the complete workflow of the TwinCAT EPLAN interface.

https://infosys.beckhoff.com/content/1033/tcecadimport/Resources/11276618507/.zip

https://infosys.beckhoff.com/content/1033/tcecadimport/Resources/11276618507.zip
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